Ergebnis 1 bis 5 von 5

Thema: IIS 6 mit SSL einrichten

  1. #1
    Avatar von flacram
    flacram ist offline Fortgeschrittener Benutzer
    Registriert seit
    17.10.2004
    Ort
    s Züri
    Beiträge
    59

    Standard IIS 6 mit SSL einrichten

    hallo zusammen,

    habe den IIS 6 auf dem server2003 installiert. Eingehend: Web und Exchange funktionieren auf Port 80. Ausgehend habe ich den SUS und auch den Exchange die ich ansprechen kann.(ich möchte aber Exchange auf Port 443 einrichten)

    Sobald ich SSL Port 443 einrichte denn geht keine Verbindung mehr.FM: die Seite kann nicht angezeigt werden. Wenn ich den den SSL deaktiviere geht es wieder.

    Das Problem taucht auch in meinem Intranet auf ich kann keine SSL Verbindung machen. (Firewall meldet das jemand zugreift : zugelassen Port 443 oder 80 aber es kommt immer die Meldung das die Seite nicht aufgerufen werden kann)

    Kann mir jemand behilflich sein ?

    vielen dank

  2. #2
    Registriert seit
    13.07.2003
    Ort
    München
    Beiträge
    630

    Standard Re: IIS 6 mit SSL einrichten

    Original geschrieben von flacram
    Sobald ich SSL Port 443 einrichte denn geht keine Verbindung mehr.FM: die Seite kann nicht angezeigt werden. Wenn ich den den SSL deaktiviere geht es wieder.

    Das Problem taucht auch in meinem Intranet auf ich kann keine SSL Verbindung machen. (Firewall meldet das jemand zugreift : zugelassen Port 443 oder 80 aber es kommt immer die Meldung das die Seite nicht aufgerufen werden kann)
    1. Hast Du auch ein Zertifikat an den IIS gebunden? Hat dieses den richtigen CN?
    2. Wieso meldet Deine Firewall einen Zugriff, wenn Du intern auf den IIS zugreifst?

    Viele Grüße
    Dieter
    Dieter Rauscher
    MVP ISA Server
    Website: http://www.msisafaq.de
    Blog: http://msmvps.com/rauscher/
    Buch: http://www.msisafaq.de/buch/

  3. #3
    Avatar von flacram
    flacram ist offline Fortgeschrittener Benutzer
    Registriert seit
    17.10.2004
    Ort
    s Züri
    Beiträge
    59

    Cool Re: Re: IIS 6 mit SSL einrichten

    Original geschrieben von Dieter Rauscher
    1. Hast Du auch ein Zertifikat an den IIS gebunden? Hat dieses den richtigen CN?
    2. Wieso meldet Deine Firewall einen Zugriff, wenn Du intern auf den IIS zugreifst?

    Viele Grüße
    Dieter

    ciao Dieter,

    1. ein Zertifikat habe ich mir selber ausgestellt und ich kann es einbinden . (Browser und auch ISS)

    2. meine Firewall meldet von extern das jemand auf Port 443 und 80 zugreift. Intern nicht.

    danke

  4. #4
    Registriert seit
    26.09.2003
    Ort
    Bern
    Alter
    43
    Beiträge
    342

    Standard

    Howdy

    Welche Zertifikatsvorlage hast Du verwendet um das Zertifikat auszustellen? Webserver? Im IIS kann man leider alle Zertifikatstypen zuweisen, auch wenn diese nicht für https geeignet sind. Oft liegt hier der Hund begraben ... achte also auf ein korrektes Zertifikat. Beim Einsatz von IIS6 kannst Du aus dem IIS6-Resource Kit das Tool selfssl.exe verwenden, um einem virtuellen Webserver ein Zertifikat zuzuweisen. Damit klappts garantiert und ist unter Umständen einfacher, als eine eigene CA einzurichten und zu betreiben.

    Ein weiterer Fehler liegt darin, dass der 443-Port nicht immer automatisch zugewiesen wird. Achte darauf, dass der Port explizit angegeben ist, ansonsten manuell angeben.

    Betreibst Du eine Desktop-Firewall auf dem Server der u.U. kein HTTPS zulässt ? Versuch mal, vom Server aus lokal eine HTTPS-Verbindung aufzubauen ...

    Hmmm ... was könnte es denn noch sein?

    Prüf mal, ob ein Listener vorhanden ist. Sobald du den Port 443 festgelegt hast und den virtuellen Webserver neu gestartet hast, kannst Du mit dem Befehl "netstat.exe -na" prüfen, ob überhaupt ein Listener für Port 443 existiert. Ziemlich zuoberst in der Liste sollte ein Eintrag sichrbar sein, der wie folgt aussieht:

    TCP 0.0.0.0:443

    Ist dieser Eintrag nicht da, liegt das Problem beim Server. Ist er da, liegt das Problem irgendwo in der Kommunikation.

    Melde Deine Erfolge oder weitere Fehlermeldungen ...

    Gruss und bis bald
    Marcel
    MCP, MCTS, MCSA, MCSAS, MCSAM, MCSE, MCSES, MCITP SA, MCITP EA, MCT, MVP SCCDM

  5. #5
    Registriert seit
    08.08.2003
    Ort
    Olten
    Alter
    58
    Beiträge
    4.023

    Standard

    beste Grüsse
    Trainer

    "Es regnete nicht, als Noah die Arche baute!"

Ähnliche Themen

  1. merak webmail in IIS 6
    Von delfin im Forum Webdesign & andere Programmiersprachen
    Antworten: 6
    Letzter Beitrag: 22.04.2008, 11:37
  2. Failed to access IIS metabase.
    Von Phil im Forum Webdesign & andere Programmiersprachen
    Antworten: 0
    Letzter Beitrag: 06.02.2006, 20:40
  3. IIS ohne SSL und trozdem kommt eine Zertifikatsmeldung
    Von mcnobrain im Forum Software: Windows, Apple, Linux...
    Antworten: 0
    Letzter Beitrag: 29.09.2005, 17:02
  4. Windows 2000 IIS 5 - SSL Certificates
    Von Nekrozol im Forum Software: Windows, Apple, Linux...
    Antworten: 7
    Letzter Beitrag: 24.08.2005, 17:38
  5. IIS für OWA einrichten
    Von Jordan im Forum Software: Windows, Apple, Linux...
    Antworten: 1
    Letzter Beitrag: 18.02.2005, 01:17

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •